Summa DC3 Problem??? Clamp will go ON and OFF Continuously?

This group is for Summa Printers & Plotters. Questions and issues, advice on all things Summa.
Post Reply
cyberdine1
Posts: 11
Joined: Fri Jun 25, 2010 8:16 am

Summa DC3 Problem??? Clamp will go ON and OFF Continuously?

Post by cyberdine1 » Tue Feb 01, 2011 1:36 am

Hi, my DC3 was working fine and suddenly after powering it up, the clamp started going up and down continuously and when the media is on...
If the media is removed, then the back rollers keep on rolling backwards non-stop like if you're removing the vinyl.
The buttoms on the back won't work to stop the rollers...
The LCD display reads:

Summa DC
Media width 910
User config 01
Menu Pause

It won't come ready. I already called summa and they said there might be 3 things, the media sensors, the buttoms or the main board.

So I was wondering if anyone have had any problem similar or like this.
I appreciate any input.
Thanks,

ByteBandit
Posts: 35
Joined: Sat Oct 31, 2009 12:05 pm

Re: Summa DC3 Problem??? Clamp will go ON and OFF Continuous

Post by ByteBandit » Tue Feb 01, 2011 7:35 am

At first clean the media sensors... if this unsolve the problem you must call the service to check your machine.

cyberdine1
Posts: 11
Joined: Fri Jun 25, 2010 8:16 am

Re: Summa DC3 Problem??? Clamp will go ON and OFF Continuous

Post by cyberdine1 » Tue Feb 01, 2011 9:02 pm

I have already cleaned it, I am going to buy the two sensors and go from there then and just hope it is it.
Thanks for the input.

Post Reply